PyRank
  • Search
  • PyPI
  • GitHub
  • Insights
  • Compare
  • Advisories
  • Ecosystem
  • About

Username Python Packages

Python packages with the GitHub topic username. Sorted by monthly downloads, with stars and forks.
soxoj
maigret

🕵️‍♂️ Collect a dossier on a person by username from 6K websites

66K 39K 3K
iojw
socialscan

Python library for accurately querying username and email usage on online platforms

9K 2K 225
qeeqbox
social-analyzer

API, CLI, and Web App for analyzing and finding a person's profile in 1000 social media \ websites

6K 24K 2K
byllyfish
precis-i18n

Python3 implementation of PRECIS framework (RFC 8264, RFC 8265, RFC 8266)

5K 20 4
thewhiteh4t
nexfil

OSINT tool for finding profiles by username

1K 3K 254
khasbilegt
django-user-email

Custom, simple Django User model with only email and name fields

259 3 1
banaxou
dsherlock

csint tool username | dark sherlock

179 38 1
banaxou
dark-sherlock

csint tool username | dark sherlock

152 38 1
abranhe
username-cli

Get the current user name on your command line

105 4 0
AnonCatalyst
ominis-osint

This Python application is an OSINT (Open Source Intelligence) tool called "Ominis OSINT - Web Hunter." It performs online information gathering by querying Google for search results related to a user-inputted query. The tool extracts relevant information such as titles, URLs, and potential mentions of the query in the results.

90 632 62
hansalemaos
genranddata

a function to create random usernames

61 0 0
benbusby
namebuster

A tool for enumerating usernames from text, files, or websites

54 89 13
jvamvas
crazy-tiger

Generate harmless random nicknames

51 0 0
WebBreacher
what-is-my-name

Community-maintained dataset of 700+ websites for finding accounts by username — powers OSINT and digital footprint tools.

50 3K 484
ajuelosemmanuel
philint

OSINT tool that allows to gather information from an email address, an username, and more !

46 28 1
jayvdb
tox-add-factor

tox-add-factor allows addition of factors on the command line, such as CI, OS, username and arch, so that they can be used to select dependencies and commands.

41 2 0
poudel
django-username-tools

A bit pragmatic username field for Django model and forms

35 7 0
    • Original data from PyPI, GitHub, and OSV; downloads served through ClickHouse
    • Sources & methodology