PyRank
  • Search
  • PyPI
  • GitHub
  • Insights
  • Compare
  • Advisories
  • Ecosystem
  • About

Password Python Packages

Python packages with the GitHub topic password. Sorted by monthly downloads, with stars and forks.
hynek
argon2-cffi

Secure Password Hashes for Python

63.2M 733 56
dwolfhub
zxcvbn

Python implementation of Dropbox's realistic password strength estimator

4.7M 718 87
frankie567
pwdlib

Modern password hashing for Python

3.7M 179 8
ulif
diceware

Passphrases to remember

717K 408 51
zopefoundation
authencoding

Password hash framework for Zope.

71K 1 4
devthat
zipencrypt

Encryption for zipfile

71K 8 1
Keeper-Security
keepercommander

Keeper Commander is a python-based CLI and SDK interface to the Keeper Security platform. Provides administrative controls, reporting, import/export and vault management.

65K 257 89
Hapag-Lloyd
rds-proxy-password-rotation

Python script to rotate the RDS credentials using a separate credential for the application.

61K 0 0
dwolfhub
zxcvbn-python

Python implementation of Dropbox's realistic password strength estimator

53K 718 87
tarunbatra
password-validator

Validates password according to flexible and intuitive specification

33K 19 3
Pawamoy
django-zxcvbn-password

Back-end and Front-end password validation with ZXCVBN

14K 90 15
khast3x
h8mail

Email OSINT & Password breach hunting tool, locally or using premium services. Supports chasing down related email

12K 5K 625
Samsung
credsweeper

CredSweeper is a tool to detect credentials in any directories or files. CredSweeper could help users to detect unwanted exposure of credentials (such as token, passwords, api keys etc.) in advance. By scanning lines, filtering, and using AI model as option, CredSweeper reports lines with possible credentials, where the line is, and expected type o

9K 230 53
patarapolw
pronounceable

Analyze passwords' memorizability and generate pronounceable words.

7K 8 1
byllyfish
precis-i18n

Python3 implementation of PRECIS framework (RFC 8264, RFC 8265, RFC 8266)

5K 20 4
Lenders-Cooperative
django-password-history

Django module meant to allow django users to keep a history of their previously used passwords.

4K 0 2
ultrahorizon
pyargon2

Simultaneously the simplest and most powerful Argon2 implemenation in Python

3K 21 4
Bing-su
passuth

argon2

2K 0 0
DerSchinken
passwordcardgenerator

Password Card Generator

2K 2 0
codingjoe
django-mail-auth

Django authentication via login URLs, no passwords required

2K 111 5
emargi
allsafe

AllSafe, A Modern Password Generator. No need to worry about passwords anymore.

2K 2 0
login-securite
donpapi

Dumping DPAPI credz remotely

2K 1K 163
QueraTeam
django-pwned

A collection of django password validators

1K 25 1
stellarsu
hashwd

Script to generate secure, human-readable passwords

1K 2 0
    • Original data from PyPI, GitHub, and OSV; downloads served through ClickHouse
    • Sources & methodology